Problems while accessing Activities page

Incident Report for Peopleware

Resolved

This incident has been resolved.
Posted Sep 06, 2023 - 09:04 UTC

Investigating

Occasional errors occur while accessing the Activities page. We are currently investigating the problem.
Posted Sep 06, 2023 - 08:43 UTC