Time-Off Beta unavailable

Incident Report for Peopleware

Resolved

This incident has been resolved.
Posted Sep 19, 2024 - 08:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2024 - 08:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 19, 2024 - 08:25 UTC