Lost access to time-off approval function or time-off period management.

Incident Report for Peopleware

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 09:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 28, 2025 - 09:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2025 - 09:40 UTC

Investigating

We are currently investigating this issue.
Posted Apr 28, 2025 - 09:19 UTC
This incident affected: Plan.